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Product Overview

Simulink® Control Design™ lets you design and analyze control systems
modeled in Simulink. You can automatically tune the gains of the Simulink
PID Controller block to meet performance requirements. With this product
you can also non-intrusively find trim points and compute exact linearizations
of Simulink models at various operating conditions. Simulink Control Design
provides tools for computing simulation-based frequency responses without
modifying your model. A graphical user interface lets you design and analyze
arbitrary control structures modeled in Simulink, such as cascaded, pre-filter,
regulation, and multi-loop architectures.

Learn More


http://www.mathworks.com/products/simcontrol/

1 Product Overview




Steady-State Operating
Points

e “What Is a Steady-State Operating Point?” on page 2-2

e “Steady-State Operating Points (Trimming) From Specifications” on page
2-3

* “magball Simulink Model” on page 2-9



2 Steady-State Operating Points

2-2

What Is a Steady-State Operating Point?

A steady-state operating point of the model, also called equilibrium or ¢rim
condition, includes state variables that do not change with time.

A model might have several steady-state operating points. For example, a
hanging pendulum has two steady-state operating points. A stable steady-state
operating point occurs when a pendulum hangs straight down. That is, the
pendulum position does not change with time. When the pendulum position
deviates slightly, the pendulum always returns to equilibrium; small changes
in the operating point do not cause the system to leave the region of good
approximation around the equilibrium value.

An unstable steady-state operating point occurs when a pendulum points
upward. As long as the pendulum points exactly upward, it remains in
equilibrium. However, when the pendulum deviates slightly from this
position, it swings downward and the operating point leaves the region
around the equilibrium value.

When using optimization search to compute operating points for a nonlinear
system, your initial guesses for the states and input levels must be in the
neighborhood of the desired operating point to ensure convergence.

When linearizing a model with multiple steady-state operating points, it
1s important to have the right operating point. For example, linearizing a
pendulum model around the stable steady-state operating point produces a
stable linear model, whereas linearizing around the unstable steady-state
operating point produces an unstable linear model.

Examples and How To

® “Steady-State Operating Points (Trimming) From Specifications” on page
2-3

e “Steady-State Operating Points From Simulation”
More About

e “Steady-State Operating Point (Trimming)”
® “Operating Point Object Includes a Subset of Simulink® Model States”



Steady-State Operating Points (Trimming) From Specifications

Steady-State Operating Points (Trimming) From
Specifications

This example shows how to compute a steady-state operating point, or
equilibrium operating point, by specifying known (fixed) equilibrium states
and minimum state values.

Code Alternative

Use findop to find operating point from specifications. For examples and
additional information, see the findop reference page.

1 Open Simulink model.

sys = 'magball’;
open_system(sys)

~iBix

File Edit VYiew Simulation Format Tools  Help

R N o s [

Refer=noe Ermor
Signal Signal W h
0.05 g 8 Mo Cutl P ot - ]
Desired Scope
Height Contmlier hlzg st

Eall Plant

Copynght 2004 2006 The MathiWarks Ine.

Ready [100% [T=0.00 |odeds G

2-3



2 Steady-State Operating Points

2 In the Simulink model window, select Tools > Control Design > Linear
Analysis.

This action starts a new project in the Control and Estimation Tools
Manager.

3 Select Operating Points and click the Compute Operating Points tab.

By default, all model states are specified to be at equilibrium (Steady
State). The Inputs and Outputs tabs are empty because this model does
not have root-level input and output ports, respectively.

ﬂ Workspace Operating Points Computs Operating Points I
- Wb Project - magball
E[E' Operating Paints Compute new operating points using | operating specifications  » l
fﬁ Default Operating
=3 Linearization Task States | Inputs Outpuml Computation Results |
= custom views State Specifications
State Value —
I~ Known I ¥ Steady State I Minimum | Ma)ﬂml.l
magball/Controller/PID ControlleriFilter
State - 1 [ 0 [ r [ [ [ anf ] Inf
magball/Controller/PID Controller/integrator f\
State - 1 [ 140071 | r | [ [ anf ] Inf |
magball/Magnetic Ball Plant/Current
State - 1 [ 7o03 | r [ W [ anf ] nf 4
magball/Magnetic Ball Plant/dhdit
State - 1 [ 0 [ r [ ~ [ anf ] Inf |
magball/Magnetic Ball Plantiheight -
g— State - 1 0.05 —— = Inf Inf__%

4 In the States tab, select Known for the height state.

The height of the ball should match the reference signal height. This height
value should remain fixed during the optimization.



Steady-State Operating Points (Trimming) From Specifications

States | inputs | Qutputs | Computation Results |

State Spedfications
State Value — -
[~ Known I [¥ Steady State I Minirnurn I Maximum
magballiController/PID Controller/Filter
State - 1 | 0 | r | [ [ anf ] Inf
magballiController/PID Controller/Integrator
State - 1 | 140071 | r | [ [ anf ] Inf
magballiMagnetic Ball PlantiCurrent
State - 1 | 7003 | r | [ [ anf ] Inf
%Ilmagneﬁc Ball Plantidhdt
State$1 | 0 [ C | [ [ anf [ Inf
magballiMagnetic Ball Plap#fEight i,
State - 1 | oos { v ) ¥ |  anf | Inf
5 Enter 0 for the minimum bound of the Current state.
States | Inputs | Qutputs | Computation Results |
State Spedifications
State Value — -
[~ Known I [¥ Steady State I Minirnurn I Maximum

magball/Controller/PID Controller/Filter

State - 1 | 0 | r | [ [ anf ] Inf

magball/Controller/PID Controller/integrator

State - 1 [ 140071 | r | [ [ anf ] Inf

magball/Magnetic Ball Plant/Current P e

State - 1 [ 7003 | r | F ([ | ) nf

magball/Magnetic Ball Plantidhdt ~— __ —

State - 1 | 0 | r | [ [ anf ] Inf

magball/Magnetic Ball Plant/height

State - 1 [ oos ] [ | [ [ anf ] Inf

6 Click Compute Operating Points.



2 Steady-State Operating Points

States | Inputs | Outputs | Computation Results |
State Specifications
State Value — -
[~ Known I ¥ Steady State I Minimum I Maximum
magball/Controller/PID ControlleriFilter
State - 1 | 0 | r | ~ [ anf ] Inf
magball/Controller/PID Controller/integrator
State - 1 | 140071 | r ~ [ anf ] Inf
magball/Magnetic Ball Plant/Current
State - 1 | 7003 | r | ~ Inf
magball/Magnetic Ball Plant/dhdt
State - 1 | 0 | r | ~ [ anf ] Inf
magball/Magnetic Ball Plant’height
State - 1 | oos ] ~ | ~ [ anf ] Inf
e ——,
Sync with Model | Import Initial Values... |(_ Compute Operating Points }

This action uses numerical optimization to find the operating point that
meets your specifications.

The Computation Results tab shows that the optimization algorithm
terminated successfully. The (Maximum Error) Block area shows the
progress of reducing the error of a specific state or output during the
optimization.



Steady-State Operating Points (Trimming) From Specifications

E! ‘Control and Estimation Tools Manager - 1ol =l

File Toolz Help
=hall=0= 1=

ﬂ Workspace Operating Points Compute Operating Points I
=W/ Project - magball

E}.Ea Operating Points Compute new operating points using I operating specifications
Lé Default Operatir
= Operating Point Statesl Inpmsl Outputs Computation Results |
E}- inearization Task LI
Ea Custom Views Optinizing to solve for all desired dx/dt=0, x(k+l)-x({k)=0, and y=ydes.

{Maximum Error) Block

{5.00000&700%:nagball,{}‘_’agnetlc Ball Plant/Current
{1.74525e-010)" magball /Magnetic Ball PFlant/dhdt
(1.74525e-010) magball/Magnetic Ball Flent/dhdt

Operating point specifications were successfully met.

Bn operating point Operating Point has been added to the node Operating
Points.

Ll

= | | _'I Sync with Mode! Import Initial Values. .. " Compute Operating Points

- Computing operating point for the model: magball.
- An operating peint called "Operating Point”™ has been added to the node Operating Points.

s L

Compute operating points.

7 Click Operating Point to evaluate whether the resulting operating point
values meet the specifications.

The Actual dx values are near zero (Desired dx), which indicates that the
operating point meets the steady state specification.

The Actual Value of the states falls within the Desired Value bounds.

ﬂ Workspace States I Inpuml Outpulsl
E‘“ Project -m..agball State I Desired Value I Actual Value I Desired dx I Actual dx
E}'-Ea Operating Points —
f.z% Default Operatir magball'Controller/PID ControlleriFilter
Operating Point [ i [ [anf,infl ] [ [ 0 [ 0
Linearization Task | ||MaaballiController/PID Controller/integrator
L3 Custom Views | ||State -1 [ [anf, ] ] 14.0071 | 0 [ 0
magball/Magnetic Ball Plant/Current
State -1 [ [o,Inf] | 7.0036 | 0 [ 42084011
magball/Magnetic Ball Plant/dhdt
State -1 [ [anf,mf] ] 0 | 0 [ -1.7453e-010
magball/Magnetic Ball Plant/height
State - 1 [ 0.05 [ 0.05 [ 0 [ 0
4 I Hl
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2 Steady-State Operating Points

8 (Optional) Select File > Generate MATLAB Code to automatically
generate a MATLAB® script.

This script contains all commands for the most recent Compute
Operating Points operation in Control and Estimation Tools Manager.

Tip Alternatively, click *] to generate code.

Related Examples

® “Steady-State Operating Points (Trimming) From Specifications” on page
2-3

® “Steady-State Operating Points From Simulation”
More About

* “magball Simulink Model” on page 2-9
® “Steady-State Operating Point (Trimming)”



magball Simulink® Model

magball Simulink Model

The Simulink model magball includes the nonlinear Magnetic Ball Plant in a
single-loop feedback system.

-ioix

File Edit WYiew Simulation Format Tools Help

DB2E&| B4 » mfio voma || 5 e

W h
m O o in Out » 1

Scope

Sontmler g nietic
Eall Flant

Gopyright 20042006 The MathWarks Inc.

Ready [1o02 [ [T=0.00 |odets v

The Magnetic Ball Plant subsystem is shown in the following figure.

2-9



2 Steady-State Operating Points

-ioix
File Edit WYiew Simulation Format Tools Help
D& & BB|cs [ r 5o [Nomal [=| =

Ready 100% odeds
4

The Magnetic Ball Plant model represents an iron ball of mass M. This ball
moves under the influence of the gravitational force, Mg, and an induced

-2
magnetic force, BL The presence of the squared term in the induced
magnetic force reé’ults in a nonlinear plant.

The inductor in the electric circuit, shown in the following figure, causes the

induced magnetic force. This circuit also includes a voltage source and a
resistor.

W%L
O

TE
h

lM g
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magball Simulink® Model

The following table describes the variables, parameters, differential
equations, states, inputs, and outputs of the Magnetic Ball Plant subsystem.

Variables h is the height of the ball.
i 1s the current.

V 1s the voltage in the circuit.

Parameters M is the mass of the ball.

g is the gravitational acceleration.

[ 1s a constant related to the magnetic force.
L is the inductance of the coil.

R is the resistance of the circuit.

Differential The height of the ball, A, is described in the following
equations equation:

% .2
M% = Mg — ﬂL
dt h
The current in the circuit, i, is described in the following
equation:
Lﬂ =V -iR
dt
States h
dh/dt
i
Inputs \%

Outputs

Examples and How To

“Steady-State Operating Points (Trimming) From Specifications” on page 2-3

2-11



2 Steady-State Operating Points
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Linearization

e “Applications of Linearization” on page 3-2

® “Open-Loop Response of Control System for Stability Margin Analysis”
on page 3-3

¢ “Bode Response of Simulink Model” on page 3-7
e “watertank Simulink Model” on page 3-12



3 Linearization

3-2

Applications of Linearization

Linearization is useful in model analysis and control design applications.
After you linearize a Simulink model at a specific operating point, you can use
your linear model to:

Compute the Bode response of the Simulink model.
Evaluate loop stability margins by computing open-loop response.

Obtain linear state-space, transfer-function, or zero-pole-gain
representation of the combined Simulink model that contains only linear
blocks.

Analyze and compare plant response near different operating points.
Design linear controller

Classical control system analysis and design methodologies require
linear, time-invariant models. Simulink Control Design automatically
linearization the plant when you tune your compensator. See “PID Control
Design Using Robust-Response-Time Tuning Algorithm” on page 4-19.

Analyze closed-loop stability.

Measure the size of resonances in frequency response by computing
closed-loop linear model for control system.

Generate controllers with reduced sensitivity to parameter variations and
modeling errors (requires Robust Control Toolbox™).

Examples and How To

“Open-Loop Response of Control System for Stability Margin Analysis”
on page 3-3

“Bode Response of Simulink Model” on page 3-7

“Steady-State Operating Points (Trimming) From Specifications” on page
2-3

More About

“Linearizing Nonlinear Models”



Open-Loop Response of Control System for Stability Margin Analysis

Open-Loop Response of Control System for Stability
Margin Analysis

This example shows how to use Control and Estimation Tools Manager to
analyze the open-loop response of a control system.

You compute a linear model of the combined controller-plant system without
the effects of the feedback signal. A Bode plot of the resulting linear model
shows the open-loop response.

1 Open Simulink model.

sys = 'watertank’;
open_system(sys)

The Water-Tank System block represents the plant in this control system
and contains all of the system nonlinearities.

il
File Edit View Simulation Format Tools Help
OEeEHES| SBR[ 422 IIZDD.D INorrnaI i el <
10 i+ P={ Fliz) =] Input Output g :l
Desired FID Controller Scope
Water Level Water-Tank System

Copyright 2004-2002 The MathWodks, Inc

Ready 100%: =0.00 ode45
4

2 In the Simulink model window, select Tools > Control Design > Linear
Analysis.

This action starts a new project in the Control and Estimation Tools
Manager.

3-3



3 Linearization

ﬂ Control and Estirnation Tools Manager EI@
File  Tools Help
il =
Wforkspace Analysis /05 | Operating Points | Linearization Results ‘

BE Project - watertank
E}Ea Operating Points

Select lineatization 1705 by right clicking an the desired line in your Simulink model

Active | Signal Description | Configuration | Open Loop

3 In the Simulink model window, define the portion of the model to linearize:

¢ Right-click the PID Controller block input signal (the output of the Sum
block). Select Linearization Points > Input Point.

¢ Right-click the Water-Tank System output signal, and select
Linearization Points > Output Point.

¢ Right-click the Water-Tank System output signal and select
Linearization Points > Open Loop.

i

File Edit Wiew Simulaton Format Tools Help

O SE&|dBE & 4 [=2]r = poo [roma = oE e B g
10 it $ P Flis) o] Input Owrtput 2x l:l
Desired PID Controller Soope
Water Lewsl| ‘Water-Tank System

Copyright 2004-2009 The MathWorks, Inc.

Ready 100% =0.00 ode45
v
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Open-Loop Response of Control System for Stability Margin Analysis

Note Do not open the loop by manually removing the feedback signal from
the model. Removing the signal manually changes the model operating

point.

4 In the Plot linear result in a list, select Bode response plot.

Linearize Model

[ Flot linear analysis result ina | Bode response plak LI

5 Click Linearize Model.

The Bode plot of the open-loop response appears in the LTI Viewer window.

6 Right-click the plot and select Characteristics > Minimum Stability

Margins.
Bode Diagram
From: Sum1 To: Water-Tank System
35
30 -
o
= 25 T
o
=
=
5 20 -
Lo}
=
1:
- Plot Types
10 Systems 4 , ) )
80 Characteristics b Peak Response
Show Minimum Stability Margins
_ Grid All stability Margins
w -90 | -
) v Full View
ﬁ Properties...
£ G)F =
o
oo L L . L . . L L L
= -1
10 10
Frequency (radizec)
LTI Viewer
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3 Linearization

The Bode plot displays the phase margin marker. Click the marker to show
a data tip that contains the phase margin value.

Bode Diagram
From: Sumi To: Water-Tank System

40 T

Magnitude {dB)

& -90 B
L7
E
o
@
g BF
System: Model %
Phaze Margin (deg): 90
o0k \ L L + . Delay Margin (zec) 3.93 i
10'2 | At frequency (radizec): 0.4 103
Cloged Loop Stable? Yes
Frequenc, ;
LTI Viewer

7 Close Simulink model.
bdclose(sys);
Related Examples

¢ “Bode Response of Simulink Model” on page 3-7

® “Steady-State Operating Points (Trimming) From Specifications” on page
2-3

More About

¢ “Linearizing Nonlinear Models”

e “watertank Simulink Model” on page 3-12

3-6



Bode Response of Simulink® Model

Bode Response of Simulink Model

This example shows how to use Control and Estimation Tools Manager to
linearize a model at the operating point specified in the model. The model
operating point consists of the model initial state values and input signals.

Code Alternative

Use linearize. For examples and additional information, see the linearize
reference page.

1 Open Simulink model.

sys = 'watertank';
open_system(sys)

The Water-Tank System block represents the plant in this control system
and includes all of the system nonlinearities.

L=
File Edit View Simulation Format Tools Help
DxEdE| s 4[5 &b = pwo | [vomal Jid | 20 =
10 Pe{ Flis) P! Input Output - :l
Desired FID Controller Scope
Water Lavel Water-Tank Systemn

Copyright 2004-2002 The MathWorks, Inc

Ready [100% [ [T=0.00 |ode4s v

2 In the Simulink model window, select Tools > Control Design > Linear
Analysis.

This action starts a new project in the Control and Estimation Tools
Manager.
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3 Linearization

ﬂ Control and Estirnation Tools Manager EI@
File  Tools Help
il =
Wforkspace Analysis /05 | Operating Points | Linearization Results ‘

BE Project - watertank
E}Ea Operating Points
ol Default Operating Active |

Line 1 Task

Ea Custarn Yiews

3 In the Simulink model window, define the portion of the model to linearize:

Select lineatization 1705 by right clicking an the desired line in your Simulink model

Signal Description | Configuration | Open Loop

¢ Right-click the PID Controller block output signal, which is the input to
the plant. Select Linearization Points > Input Point.

¢ Right-click the Water-Tank System output signal, and select
Linearization Points > Output Point.

The linearization I/O markers appear in the model.

Input Point Output Point
=] watertank * -0l =|
File Edit View Simulaton Format Tools Help
D|ﬁu§|éﬂﬁ|¢'ﬁ>ﬁ}|ﬂeli IIZDD.D INor'naI j|§
\j A
10 i+ | Flis) P Input  Output 3 - 1
Diesired FID Controller Scope
Water Lavel Water-Tank System
Copyright 2004-2008 The MathWorks, Inc
Ready [100%% [ [ |ode4s A

4 Right-click the Water-Tank System output signal and select Linearization
Points > Open Loop.



Bode Response of Simulink® Model

This command removes the effects of the feedback signal on the
linearization without changing the model operating point. The loop opening
marker appears in the model.

Loop opening

— Flig $—p|npm Qutput 3

FIC Controller

MiaterTank System

The Analysis I/Os tab of the Control and Estimation Tools Manager
updates to show linearization input and output points.

4} Warkspace Analysis 10s | Operating Paints | Linearization Results|
=W Project - watertank
E‘"[E Operating Paints Select linearization IF0s by right clicking on the desired line in your Simulink model
|2t Default Operating f Bctive Signal Description Configuration | Open Lo‘o,
EH - Ear'z'-’t":'n Task Block: watertank/PID Controller
L Custam Wiews Port: 1 I ]
Sighal Marme: | Input - =
Block: watertank\WVater-Tank Systern
Fort; 1 r 1
Signal Marme: | Output - /

Note Do not open the loop by manually removing the feedback signal
from the model. Removing the signal manually changes the operating
point of the model.

5 Click the Operating Points tab.

The model operating point is already selected.



3 Linearization

3-10

Analysis If0s  ©Operating Poinks | | inearization Results |

Select operating paint type: I Existing operating paints d

% Linearize at the operating point currently specified in the Simulink mode].;

(" Linearize at one or more of the following operating points:

Operating Point Description

Default Operating Point Maodel operating paint y

e

6 In the Plot linear result in a list, select Bode response plot.

Linearize Model [ Flot linear analysis result ina | Bode response plak LI

7 Click Linearize Model.

The Bode plot of the linearized system appears in the LTI Viewer window.
This Bode plot looks like a stable first-order response, as expected.



Bode Response of Simulink® Model

lagnitude (dB)

Phase (deg)

8 Close Simulink model.

bdclose(sys);

Related Examples

80

Bode Diagram

From: PID Controller To: Water-Tank System

10

107

Frequency (radizec)

10"

® “Open-Loop Response of Control System for Stability Margin Analysis”
on page 3-3

e “Steady-State Operating Points (Trimming) From Specifications” on page

2-3

More About

¢ “Linearizing Nonlinear Models”

e “watertank Simulink Model” on page 3-12

3-11



3 Linearization

watertank Simulink Model

The Simulink model watertank model includes the nonlinear Water-Tank
System plant and a PI controller in a single-loop feedback system.

-ioix
File Edit View Simulaton Format Tools Help
D|@n§|%ﬁ|@=§?|9cﬂ_’|} IIZDD.D INorrnaI j|§

hd
¥

10 _ » Pl plinput  Output pl 1

Desired FID Controller Scope
Water Level ‘Water-Tank Systern

Copyright 2004-2009 The MathWorks, Inc.

Ready [100% [ [ |ode4s v

The Water-Tank System is shown in the following figure.

Slwatertank,/Water-Tank System 10l =|

File Edit Wiew Simulation Format|TO0Is Help

DEH&E sBR|(e= o2 s

arh Square
Root

Fl1o0% [ |odets v

Water enters the tank from the top at a rate proportional to the voltage, V,
applied to the pump. The water leaves through an opening in the tank base
at a rate that is proportional to the square root of the water height, H, in
the tank. The presence of the square root in the water flow rate results in a
nonlinear plant.
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watertank Simulink® Model

& Woter in

bV

The following table describes the variables, parameters, differential
equations, states, inputs, and outputs of the Water-Tank System.

Variables H is the height of water in the tank.

Vol is the volume of water in the
tank.

V is the voltage applied to the pump.

Parameters A is the cross-sectional area of the
tank.

b i1s a constant related to the flow
rate into the tank.

a 1s a constant related to the flow
rate out of the tank.
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3 Linearization

3-14

Differential equation

iVoZ =A
dt

ﬁ=bV—ax/ﬁ
dt

States H
Inputs \%
Outputs H




PID Control Design

¢ “Automated Tuning of Simulink PID Controller Block” on page 4-2

® “Designing a PID Controller Using Robust-Response-Time Tuning
Algorithm and Bode Graphical Design” on page 4-14
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Automated Tuning of Simulink PID Controller Block

In this section...

“Introduction” on page 4-2

“Introduction of the PID Tuner” on page 4-2

“Opening the Model” on page 4-3

“Design Overview” on page 4-3

“Opening the PID Tuner” on page 4-3

“Initial PID Design” on page 4-4

“Displaying PID Parameters” on page 4-5

“Adjusting PID Design in the PID Tuner” on page 4-7

“Completing the Design in the Extended Design Mode” on page 4-8
“Writing the Tuned Parameters to PID Controller Block” on page 4-12

“Completed Design” on page 4-12

Introduction

Introduction of the PID Tuner

PID Tuner provides a fast and widely applicable single-loop PID tuning
method for the Simulink PID Controller blocks. With this method, you can
tune PID parameters to achieve a robust design with the desired response
time.

A typical design workflow with the PID Tuner involves the following tasks:
(1) Launch the PID Tuner. When launching, the software automatically
computes a linear plant model from the Simulink model and designs an
initial controller.

(2) Tune the controller in the PID Tuner by manually adjusting design criteria

in two design modes. The tuner computes PID parameters that robustly
stabilize the system.

4-2



Automated Tuning of Simulink PID Controller Block

(3) Export the parameters of the designed controller back to the PID
Controller block and verify controller performance in Simulink.

Opening the Model

Take a few moments to explore the model.

Open the engine speed control model with PID Controller block
open_system( 'scdspeedctrlpidblock');

) Thecttie A, |

Cambustion

Speed i e ] o e Engine
Rafaranis —*E Sped W A Chargs ——— A s
Freging harge
Torqon i
N

[ e

— U]
Throtife & Manifold

Inducton tn
Fowear Steske Dalay

Duag T

Copyright 20042000 The Mathwass, In:

Design Overview

In this demo, you design a PI controller in an engine speed control loop. The
goal of the design is to track the reference signal from a Simulink step block
scdspeedctrlpidblock/Speed Reference. The design requirement are

® Settling time under 5 seconds
e Zero steady-state error to the step reference input.
In this example, you stabilize the feedback loop and achieve good reference

tracking performance by designing the PI controller scdspeedctrl/PID
Controller in the PID Tuner.

Opening the PID Tuner

To launch the PID Tuner, double-click the PID Controller block to open its
block dialog. In the Main tab, click Tune.
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Main PID Advanced I Data Types State Attributes
—Controller settings

Controller form: |Paralle| x|
Propartional (P): | 1
Integral (I): | 1

Tune... |

Initial PID Design

When the PID Tuner launches, the software computes a linearized plant
model seen by the controller. The software automatically identifies the plant
input and output, and uses the current operating point for the linearization.
The plant can have any order and can have time delays.

The PID Tuner computes an initial PI controller to achieve a reasonable
tradeoff between performance and robustness. By default, step reference

tracking performance displays in the plot.

The following figure shows the PID Tuner dialog with the initial design:
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) PID Tuner (scdspeedctripidblock/PID Controller) _|E||ﬂ
| = B &M E | (5] | 57 @  Design mode:IBasic vI Form: Parallel  Type: PI

1, ClosedHoop system with controller gains defined in the PID block is unstable and not displayed.

Plot: | Step hd Respaonse; I Reference tracking - | I~ show block response Show parameters S
14 T T T T T
TP E—— SR SR SR AR— AR .
L [ o e TEeenno- s .
@ 08 ------eieee o e L RRELE SEEEEEEEEEERRELED EERRELEEEEEEEEE e
= 1 1 ]
= : : :
[=8 1 ] ]
£ BB - R LR R R EEEEE LR R ERCEEE TR e
(17 T bl P 4
1)) I e bemmcm e oo o ceiaos -
Tuned response
; | | | I
0 0.5 1 1.5 2 25 3
Time (2ec)
Interactive tuning
Response time: 0.673 sec
: 4 :
Slower Faster
‘}' [~ Automatically update block parameters 0K Cancel Apply | Help |

Displaying PID Parameters

Click the Show parameters arrow to view controller parameters P and I, and
a set of performance and robustness measurements. In this example, the
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initial PI controller design gives a settling time of 2 seconds, which meets
the requirement.

The following figure shows the parameter and performance tables:
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Adjusting PID Design in the PID Tuner

The overshoot of the reference tracking response is about 8 percent. Because
the response performance is limited in many systems with time delays, you
need to slow down response speed to reduce overshoot. Move the response
time slider to the left to increase the closed loop response time. Notice

that when you adjust response time, the response plot and the controller
parameters and performance measurements update.

The following figure shows an adjusted PID design with an overshoot of zero

and a settling time of 4 seconds. The designed controller effectively becomes
an integral-only controller.
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4-8

) PID Tuner (scdspeedctripidblock/PID Controller)
| E, B M | & | 57 @  Design mode:l I Form: Parallel  Type: P

Plot: | Step hd Response: I Reference tracking Vl I~ show block response
T K
:
; F
| I
! [
. r
i -
o ' -
=2 1
£ i
E : F
: :
; (
. F
i
i L
F
. l
i
I
2
Time (sec) =
Interactive tuning
Response time: 3.4 sec
(] '
1 ) 1
Slower
J' ™ Automatically update block parame

Completing the Design in the Extended Design Mode

To reduce the overshoot while maintaining the settling time of 2 seconds, you
must tradeoff between controller performance (measured by settling time)
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and robustness (measured by overshoot). You can perform such a trade-off in
the Extended design mode of the PID Tuner.

To switch to the Extended design mode, select Extended in the Design Mode
dropdown menu in the toolbar. The following figure shows the PID Tuner in
the Extended design mode with the integral only controller designed in the
previous section:
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} PID Tuner (scdspeedctripidblock/PID Controller)
EE IR E I R R

Plot: | Step v Response: | Reference tracking Vl I~ Show blodk response
: ! ! ! : ! [
| | | | | ;
L | A EeT T T o T T B n I
i ; i | | [
i ! i i i "
L b B e o i o e e b e s i e e a 12
k=) ] 1 1 ] ]
2 ] 1 1 ' 1
= ) | i ) )
i | i i i f
- — T —  S— L vsmmemusnred A S 1
: ! ! ! ! :
! : i 3 ) c
. e s — B T — |
) | i ) : F
! ! ! ! Tuned response ’
0 | | | | I
0 1 2 3 4 5 & i
Time (zec) L
~Interactive tuning
Bandwidth:
(4] '
1 ) ]
0.295 Sl
Phase margin:
1
] ] )
L] 45
J I~ Automatically update block parame

There are two sliders in the Extended design mode. You can adjust
performance with the Bandwidth slider. Large bandwidth results in fast
response. You can also adjust robustness with the Phase margin slider. Large
phase margin results in small overshoot. Move around both sliders to achieve
the settling time of 2 seconds and zero overshoot. One way to achieve this is
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e Bandwidth of 1.23 rad/sec

® Phase margin of 72 degree

The following figure shows the PID Tuner with these settings:

) PID Tuner (scdspeedctripidblock/PID Controller)

| &, G (i""p’E| & | 5 @ Design mode:IExhended vI Form: Parallel  Type: PI

Plot: | Step hd Response: I Reference tracking hd | I~ show block response
! ) : ) ) P
s s s s :
| P N N . B I
/ 1 1 1 [
: : : : "
P kb th bbb Gl gTTTTmmmmmmmpemnmmmonenees prTTmmmmeeees JrTTTTs prTTTes n L2
= [ ' ' '
=} [ ' ' '
g s s s s .
D& emmmmmmmmmee g LT EEEEPY SEPEEEPPPEEEES D OLEEEES R it S ECGEEEEEEE | -
: : : : I
1 1 1 1 :
R R S S M |
1 1 1 : F
' ' ' Tuned response
1 1 1 !
0 | | | I :
0 0.5 1 15 2 25 5 35
Time (sec) L
~Interactive tuning
Bandwidth:
(4] |
1 ) 1
0.295 2,95
Phase margin:
\ \
4] 45
‘}' ™ Automatically update block parame
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Writing the Tuned Parameters to PID Controller Block

After you are happy with the controller performance on the linear plant
model, you can test the design on the nonlinear model. To do this, click
Apply in the PID Tuner. This action writes the parameters back to the PID
Controller block in the Simulink model.

The following figure shows the updated PID Controller block dialog:

main | PIDAdvanced | DataTypes | State Atmbutes |
—Controller settings

Controller form: IParaIIeI ;I

Proportional {P): I 0.00125515099585925

Integral (I): |0.00406446 440382657

Completed Design

The following figure shows the response of the closed-loop system:

) Engine Speed (rpm) =]
g8 LPLL ARE B A K

The response shows that the new controller meets all the design requirements.
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You can also use the SISO Compensator Design Tool to design the PID
Controller block. When the PID Controller block belongs to a multi-loop design
task. See the demo "Single Loop Feedback/Prefilter Compensator Design".

bdclose('scdspeedctrlpidblock')
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Designing a PID Controller Using Robust-Response-Time
Tuning Algorithm and Bode Graphical Design

In this section...

“About This Tutorial” on page 4-14

“PID Control Design Using Robust-Response-Time Tuning Algorithm” on
page 4-19

“PID Control Design Using Bode Graphical Tuning” on page 4-28

“Closed-Loop Simulation of Simulink Model” on page 4-32

About This Tutorial

® “Objectives” on page 4-14
e “About the Model” on page 4-14
¢ “Requirements for the Compensator Design” on page 4-18

® “Overview of the Compensator Design Process” on page 4-18

Objectives

In this tutorial, you learn how to use the Simulink Control Design GUI to
design a PID controller for a single-loop feedback system that is operating at
the operating conditions specified in the Simulink model. You accomplish the
following tasks:

¢ Configure the model and GUI for compensator design.

¢ Design a PID compensator using the robust-response-time tuning
algorithm and Bode graphical design.

e Simulate the closed-loop nonlinear model.

About the Model

¢ “watertank_comp_design Simulink Model” on page 4-15

e “Water-Tank Subsystem” on page 4-15
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e “Controller Subsystem” on page 4-18

watertank_comp_design Simulink Model. The watertank_comp_design
model, shown in the following figure, contains the Water-Tank System
plant and a simple proportional-integral-derivative (PID) controller, called
Controller, in a single-loop feedback system.

-loix

File Edit View Simulaton Format Tools Help

DSHE $BB|c= 4|02 af e Hampe

Errar Out1 ] Input Output - |:|

Desired Scope

Water Lavel

Controller ‘Water-Tank System

Copyright 2004-2008 The MathWerks, Inc.

Ready [100% [ [ |ode4s v

To view the Water-Tank System and the Controller, double-click the
corresponding subsystem in the watertank_comp_design model. For
descriptions of these subsystems, see the following topics:

* “Water-Tank Subsystem” on page 4-15
e “Controller Subsystem” on page 4-18

Water-Tank Subsystem. The Water-Tank subsystem of the
watertank_comp_design model appears in the following figure.
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E!wa tertank_comp_design/Water-Tank System - | Ellll

File Edit View Simulaton Format Tools Help

DEH&E sB@B|e=>2 |02 » aF

alk Square
Root

Fl100% [ [ |ode4s v

This model represents the water-tank system depicted in the following figure.

& Woater in

bv

Tank

Water out

avH

Water enters the tank from the top at a rate proportional to the voltage, V,
applied to the pump. The water leaves through an opening in the tank base
at a rate that is proportional to the square root of the water height, H, in
the tank. The presence of the square root in the water flow rate results in a
nonlinear plant.
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The following table describes the variables, parameters, differential
equations, states, inputs, and outputs of the water-tank system.

Variables H is the height of water in the tank.

Vol is the volume of water in the
tank.

V is the voltage applied to the pump.

Parameters A is the cross-sectional area of the
tank.

b is a constant related to the flow
rate into the tank.

a 1s a constant related to the flow
rate out of the tank.

Differential equation
Dyvor=a _yv_oyE
dt dt

=

States
Inputs \%
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Outputs H

Controller Subsystem. The Controller subsystem appears in the following
figure.

E! watertank_comp_design;/Controller

File Edit WYiew Simulation Format Tools Help

EEEEE R R

1) | FIDis) » 1
Emor I_I Cutl
FID Contmlier
Fl1o0% [ |odets v

This model contains a PID Controller block that controls the height of the
water in the Water-Tank System.

Requirements for the Compensator Design

The PID controller you design in this tutorial must control the Water-Tank
System response such that the:

e QOvershoot is less than 5%.

e Rise time is less than 5 seconds.

Overview of the Compensator Design Process

The process for designing a compensator for the Water-Tank System in this
tutorial includes the following tasks:

® Configuring the model and GUI for the design.

® Designing a PID compensator using the robust response time tuning
algorithm.

® Tuning the compensator using the Bode design technique.
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® Simulating the closed-loop Simulink model with the compensator design to
analyze the system dynamics.

Simulink Control Design tools work only with linear plant models. Because
the Water-Tank System is nonlinear, Simulink Control Design automatically
linearizes the model about the model operating point, by default. The
linearization provides a valid approximation of the nonlinear model in a
region around the operating point. For more information about linearization
and how the operating point impacts linearization results, see Chapter 3,
“Linearization”.

PID Control Design Using Robust-Response-Time
Tuning Algorithm

In this portion of the tutorial, you design a compensator using the automated
PID robust-response-time tuning algorithm. This tuning method tunes the
PID gains to maximize bandwidth and optimize phase margin.

1 Open the watertank_comp_design model by typing the model name in
the MATLAB Command Window:

watertank_comp_design

The command opens the watertank_comp_design model in Simulink, as
shown in the following figure.

-loix

File Edit View Simulaton Format Tools Help

D SEHES| BB et b af  [Nom ClEs B e

Errar Out1 ] Input Output - |:|

Desired Scope
Water Levsl Controller Water-Tank System

Copyright 2004-2008 The MathWerks, Inc.

Ready [100% [ |ode4s v
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2 In the watertank_comp_design model window, select Tools > Control
Design > Compensator Design.

This action opens the Control and Estimation Tools Manager with the
Simulink Compensator Design Task node selected.

E! Control and Estimation Tools Manager _ia ll

File Tools Help =0l

i Nl N = |

ﬂ Warkspace

=l Project - watertank_comp_c
= [E Operating Points Select the blocks to tune: Select Blocks. .. |

"=l Default Operating Pr

el fSirulink Compensator D

Tunable Blacks I Closed-Loop Signals | Operating Points |

Tune? I Block

= _>| Tune Blocks., .. | Help |

NI

3 Select the PID Controller block as the block to tune.
a In the Tunable Blocks tab, click Select Blocks.

This action opens the Select Blocks to Tune window.

b Inthe watertank_comp_design tree, select the Controller subsystem.

¢ Select the Tune? check box for PID Controller.
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Eselect Blocks to Tune

I§| watertank_comp_design Belect blocks in the kable below to tune:
Controller
% Water-Tank System e - Bzttt
3 e

Highlight: Selected Block |

d Click OK.
4 Define the closed-loop systems for which you want to analyze the response.

The input and output points of the closed-loop path are already defined in
the watertank _comp_design model. If you needed to add or define them,
you would use the following steps:

a In the watertank_comp_design model, right-click the output of the
Desired Water Level block, and select Linearization Points > Input
Point.

This action displays the % symbol on the signal line. This symbol
indicates the input of the closed-loop path.

b Right-click the output signal from the Water-Tank System, and select
Linearization Points > Output Point.

This action displays the 1 symbol on the signal line. This symbol
indicates the output of the closed-loop path.
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The Simulink model now resembles the following figure.

=i

File Edit View Simulaton Format Tools Help

DEH&|$BER(e 49 @b = poo |Nm SEsBE

3 Errar Out1 ] Input Output 3 - |:|

Step Scope
Controller Water-Tank System

Copyright 2004-2008 The MathWerks, Inc.

Ready [100% [ [ |ode4s v

5 In the Control and Estimation Tools Manager, click Tune Blocks to open
the Design Configuration Wizard. Click Next.

6 Step 1 of the Design Configuration Wizard prompts you to select the design
plots you will use to tune the controller. Accept the default settings and
click Next.

7 In Step 2 of the Design Configuration Wizard, specify the type of plot for
analyzing the response.

a In the Analysis Plots area, select Step for the Plot Type corresponding
to Plot 1.

b In the Plots section of the Contents in Plots pane, select 1 for Closed
Loop from Desired Water Level to Water-Tank System.
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E! Design Configuration Wizard

~Step 2 of 2: Select Analysis Plots

~Analysis Ploks
Plat 1 Flat 2 Flat 3 Flat 4 Flat 5 Flat &

Flot Type | Step LI INone LI INone LI INone LI INone LI INone LI

~Conkents of Plats

Plots
1121345 All
W ||| T |Closed Loop From Desired ‘Water Level to Water-Tank System

Responses

-

Add Responses ... |

8 Click Finish.

The software performs the following actions:

¢ Linearizes the Simulink model about the operating point specified in
the model.

¢ (Creates a SISO Design Task node under the Simulink Compensator
Design Task node.

¢ QOpens the following plot windows:

= LTI Viewer for SISO Design Task window, which shows the
closed-loop Step Response plot of the linearized model

= SISO Design for SISO Design Task window, which is empty

You do not use in this window in this section of the tutorial. Keep this
window open for the next section of the tutorial.

The Control and Estimation Tools manager resembles the following figure.
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E! Control and E:
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watertank comp design/Controller/PID Controller

Closed Loop Input Signals:
watertank comp_design/Desired Water Lewel, outhut port 1

Closed Loop Output Sigmals:
watertank comp design/Water-Tank Svstem, ocutput port 1

Loop Configuration. .. | Corfigure additional loop openings for multi-loop design.

KT —

System Data ... | Impart data For compensatars and fixed systems,
Sample Time Conversion ... | Change the sample time of the design.
Store Design | Update Simulink Block Parameters

I~ &utomatically update block parameters Help |

SISO Design Task Mode.

s L L

The Step Response plot shows an overshoot that does not meet the
overshoot design requirement of less than 5%.
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-loix

File Edit Window Help
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Step Response
From: Step To: Water-Tank System
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LTI Wiewver ¥ Real-Time Update

9 In the Automated Tuning tab of the SISO Design Task node in the
Control and Estimation Tools Manager, select PID Tuning as the Design

method.

10 In the Specifications area, select the following options:
¢ Controller type: PI

¢ Tuning algorithm: Robust response time
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Architecture | Compensator Editor | Graphical Tuning | Analysis Plots Automated Tuning |

Design method: IPID Tuning LI

Compensator

(1 +195)
...Controller fPID Controller LI = 0.0016046 x

Spedifications

Tuning method: I Robust response time
Design options
Controller Type: P {8 * PI = PD " PID

¥ Design with first order derivative filter

Design mode: I Automatic (balanced performance and robustness)

11 Click Update Compensator.

|

Update Compensator |

This action computes the PI values for the compensator using the robust
response time tuning algorithm and updates the Step Response plot.

Tip You can view the PI values in the Parameter tab of the Compensator

Editor tab in the SISO Design Task node.

12 Evaluate whether the compensator design meets the design requirements
by analyzing the overshoot and the rise time, as follows:

a Right-click the Step Response plot and select the following options:

¢ Characteristics > Peak Response

e Characteristics > Rise Time

These actions add a plot marker to the plot for each characteristic,

shown as blue dots.

b Left-click each blue dot to open the corresponding data marker.

The data markers show the following response characteristics:
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e The overshoot is 11.6%.
e The rise time is 82.2 seconds.

<) LTI Viewer for SISD Design Task
File Edit ‘window Help

D& = =k

Step Rasponse
From: Dasired Water Level To: Water-Tank System

oal! 110 Dessired) Wiater Level to Water-Tank System

| Fisa Tima {per); 82.2

Amplitucke

04F

(3]

System: Closed Loop from Desired Water Leval to Watar-Tank System
102 Desired Water Level fo Wiater-Tank System
Peak ampltuck: 1.12

Cwershect (%): 11.6

Attime (sec): 171

i System: ) ser Loop from Desired Watar Level fo Wiater- Tank System

|
|
|
|
|
1
|
3

Time (sec)

LTI “igwmeer

¥ Real-Time Updste

This system response with the PID compensator exceeds the maximum
allowed overshoot of 5%. The rise time is much slower than the required

rise time of 5 seconds.

You decrease the rise time by increasing the gain of the compensator, as
described in “PID Control Design Using Bode Graphical Tuning” on page

4-28.

Tip You can also decrease the rise time by adjusting the loop bandwidth.
First, select Interactive (adjustable performance and robustness)
from the Design Mode menu. Then, move the Bandwidth slider to the
right. Finally, click Update Compensator to design a new compensator

for the new target bandwidth.
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PID Control Design Using Bode Graphical Tuning

In this example, you decrease the rise time of the Water-Tank System
response by increasing the compensator gain using Bode graphical tuning.

Bode graphical tuning lets you design a compensator by manipulating Bode
diagrams of the open-loop response. This process is also called loop shaping.

You must have already designed an initial compensator using PID tuning,
as described in “PID Control Design Using Robust-Response-Time Tuning
Algorithm” on page 4-19.

To design a compensator using Bode graphical tuning:

1 In the Control and Estimation Tools Manager, select the Graphical
Tuning tab of the SISO Design Task node.

2 In the Plot Type cell that corresponds to Plot 1, select Open-Loop Bode.
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E! Control and Estimation Tools Manager | _ O] x|
File Edt Tools Help
=" N
Q Workspace Architecture I Compensator Editor - Graphical Tuning I Analysis PIDtsI Autornated Tuning I
EG Praject - watertank_comp_d¢ | “pegign plats configuration
[+ ©perating Points -
= Simulink Compensator De Plot; Available OpenfcClosed Loop to Tune Flok Type
ﬂ Flot 1 Open Loop 1 || ©pen-Laop Bode =
Plot 2 Open Loop 1 ¥ || Mone -
Plot 3 Open Loop 1 _* || Mone |
Flot 4 Open Loop 1 7 || Mo |
Flot 5 Open Loop 1 ~ || Mane -
Plot & Open Loop 1 ¥ || Mone -
Summary of available OpenfClosed loops to tune:
Loop Mame | Loop Description I
Open Loop 1 ‘Open Loop at oukport 1 of PID Controller |
Select Mew OpenfClosed Loop to Tune ... | Show Design Plot |
‘I I _'I Store Design Update Simulink Block Parameters | I Automaticalky update block parameters Help |
=
-]
SISO Design Task Mode. 4

This action creates an Open-Loop Bode plot in the SISO Design for SISO
Design Task window. This plot shows a Bode plot of the linearized model
with the compensator designed using automated PID tuning.
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3 In the SISO Design window, drag the Bode Magnitude line upward to
increase the gain. As you adjust the gain, view the affects on the closed-loop
response in the Step Response plot.

). SIS0 Design for SIS0 Design Task =]

File Edit Wiew Designs Analysis Tools ‘Window Help N
X o Y (=
X o % w88

Open-Loop Bode Editor for Open Loogp 1 (L1)

70
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a0

40
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20 -
G Inf
10 Freo: Mabl

Stable loop
I I A | I I L1l

Phase (deg)
o
[43]
T
1

P.M.: 897 deg
Freq: 0.2 Hz

RN O S R e P .
107 10 107 107 10

Frequency (Hz)

Open-loop magnitude plat.
Left click and move this curve up or dovn to adjust the gain of watertank_comp_designi/controllerfpid contraller

By increasing the gain, you increase the bandwidth and speed up the
response. One possible compensator design that meets the tutorial
requirements has the following parameters:

e P=5.0368
e 1=0.11434
L[] D:O
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Tip You can view the parameter values corresponding to the gain
adjustment you made in the Bode Magnitude plot in the Compensator
Editor tab of the SISO Design Task. You can also adjust the parameter
values in this tab.

4 Evaluate whether the compensator design meets the design requirements
by analyzing the overshoot and the rise time, as follows:

a Right-click the Step Response plot and select the following options, if you
have not done so already:

¢ Characteristics > Peak Response
¢ Characteristics > Rise Time

These actions add a plot marker to the plot for each characteristic,
shown as blue dots.

b Left-click each blue dot to open the corresponding data marker.

The data markers show the following response characteristics:
® The overshoot is 0.437%.

e The rise time is 1.72 seconds.
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This compensator design satisfies the design requirements of less than 5%
overshoot and less than 5 second rise time.

Closed-Loop Simulation of Simulink Model

In this example, you simulate the nonlinear closed-loop Simulink model
that includes a PID controller to determine how well the design meets the
requirements.

You must have already designed the compensator, as described in “PID
Control Design Using Bode Graphical Tuning” on page 4-28.

1 In the Control and Estimation Tools Manager SISO Design Task node,
click Update Simulink Block Parameters.

This action writes the compensator parameters into the PID Controller
block of the Controller subsystem in the Simulink model.
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Tip You can view the PID Controller block parameters in the Function

Block Parameters Dialog box. To open this dialog box, double-click the
PID Controller block.

E! Function Block Parameters: PID Controller [ x|

—PID Controller

-

This black implements continuous- and discrete-time PID contral algorithms and includes advanced Features such as
anti-windup, external reset, and signal tracking. You can tune the PID gains automatically using the ‘Tune...' button
(requires Simulink Control Design).

Contraller: IPID

i Time-domain:

% Continuous-time

" Discrete-time

IMain | PID Advanced | Data Types State Attributes
—Contraller settings

Controller Form; IParaIIeI j
Proportional (P): |5.U368

Integral (I Jo.11434

Derivative (D) ID Filter coefficient {M): I 100

- Initial conditions

Source: ||nterna| x|

Inkeqgrakor: I 1.2649

Fiker: |a

Extetnal reset: Inone

™ Ignore reset when linearizing

™ Enable zero-crossing detection

-
4| | B
J oK I Cancel | Help | Apply. |

2 In the Simulink model, double-click the Scope block to open the Scope block
window.

3 In the Simulink model, click 4 to simulate the model. Then, click ﬁ
to autoscale the axis.
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This action updates the Scope window with the response of the nonlinear
model with the compensator design. This simulation shows that the rise time
is less than 5 seconds and there is minimal overshoot. Thus, this compensator
design meets the requirements of less than 5% overshoot and less than 5
second rise time.
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Examples

Use this list to find examples in the documentation.



A Examples

Getting Started

Chapter 2, “Steady-State Operating Points”

“Open-Loop Response of Control System for Stability Margin Analysis’
on page 3-3

“Bode Response of Simulink Model” on page 3-7

Chapter 4, “PID Control Design”

i

Automated Tuning of Simulink PID Controller Block
“Automated Tuning of Simulink PID Controller Block” on page 4-2
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